RIP v2 in nutshell

1, RIP does not form adjacency for each other,  nor do they use hello protocol. It just send out update to the mulitcast destination ip 224.0.0.9 with UDP protocol port 520. RIPv2 router can also configured to use the 255.255.255.255 broadcast ip address, but this is not commonly done.

RIP can also send unicast update, when “neighbor ip-address” command is configured, identifys a neighbor to which unicast RIP updates will be sent.

RIPv2 has only 2 types of messages: requests and Responses

Update interval is 30 seconds by default, update will be full update, when routes change, update will be triggered as well.

2, RIPv2 convergence and loop prevention is realized by the following functions:

  • Counting to Infinity(16)
  • Split Horizon(should not be enabled in point-to-mulitpoint segment)
  • Route Poisoning
  • Split Horizon with Poisoned Reverse
  • Triggered update
  • Update time (30 secs by default)
  • Invalid after time (180 secs by default)
  • Holddown timer (180 secs by default)
  • Flushed after timer (240 secs by default)

When a router has one interface shutdown, router will flush the poisoned routes to all of other interfaces, the update will been sent immediately. When a router has a link down, after “Invalid after time”, the route will be set as invalid, holddown timer starts, after 60 secs, route will be flushed and holddown timer reset, the route change will trigger update as in the first scenario.

3, Routes can be filtered in both “in” and “out” direction by using distribute-list

4, RIPng for IPv6

5, “clear ip route *” command will clear the routing table entry and with RIP, sends RIP requests, quickly rebuilding the routing table

 

IS-IS in nutshell

1, IS-IS is using NASP address to build up adjacency between each node, not IP address.

2, IS-IS is used to solve L1 and L2 routing problem described in

https://yingsnotebook.wordpress.com/2017/05/27/osi-network-tcpip

Especially L1 is similar with OSPF Not So Stub Totally Stub area, L1 area has no information about l2 routing and any other l2 area’s routing, it has only a default router (L1L2 router) which will connect this L1 area to L2 area; L2 area is similar with OSPF backbone area, which has information of both L2 and L1 areas.

When OSI network model is used, L2 will carry only area id info because L2 only need to forward the traffic towards correct L1 area, it does not have to know all ES address in L1 area. When IP is used, L2 will have IP information for networks directly connected in L2 router, and also the networks routes learned from L1 route calculation.

L1L2 router will have two IS-IS link databases, one is for L1 area which it connects to, the other is for L2. L1 and L2 databases are separated and can not be shared with each other, but L1L2 router will advertise routes learned according to L1 calculation to L2 database.

3, In IS-IS there are two types of network link: point-to-point and broadcast link. While point-to-multipoint can be simulated as several point-to-point links.

All interfaces in broadcast link will participate in DIS selection, like DR and BDR selection in OSPF broadcast link, but unlike DR and BDR role in OSPF, DIS in IS-IS is not the only one router which can send out LSP update, instead, all routers in  IS-IS broadcast link can send out LSP update. DIS is used to:

  • Help routers on a broadcast segment to synchronize
  • Representing the broadcast segment in the link-state database as a standalone object- The Pseudonode

4, Unlike OSPF which has several types of LSA, in IS-IS each router generate only one LSP, which includes all routes information of the router, LSP can be very long and need to be segmented to transfer in Layer two network, a sequence number will be used to identify the LSP packet sent by each router.  Router selected as DIS will generate 2 LSP: One is the general LSP for routing information, the other is Pseudonode LSP to indicate broadcast segment information. LSPID will be system ID + Pseudonode ID(local circuit ID of the interface)

5,  IS-IS has 3 adjacency states:

  • Down: the initial state
  • Initializing: IIHs have been received from the neighbout, but it is not certain that the neighbor is properly receiving this routers IIH
  • Up: IIHs have been received and also it is certain that the neighbor is properly receiving this router’s IIHs

6, IS-IS is a true multiprotocol routing protocol in the sense that it does not require any particular Layer 3 routing to carry it packets, and in a single instance, it can carry informaton of destination described by different address families, for example IPv4 and Ipv6 can be carried at the same time a single LSP and maintained in the same link state datebase.

OSI network & TCP/IP

OSI teminology: ES (end system)  is used as host in TCP/IP, IS( Intermediate System) is used for a router

In network layer of OSI reference model, there are 2 modes for end-to-end communication: connectionless-mode and connection mode. For connection-oriented mode, an adaptation of the x.25 is used, there is no analogous connection-oriented network layer protocol in TCP/IP. Connectionless-mode network protocol (clns) is to OSI networks what IPv4/v6 are to TCP/IP networks.

NSAP address is the address used in OSI reference model, unlike ip address, each IS node has only one NSAP address, each interface on the IS node is represented with local circuit ID. NSAP has minimum 8 octets, with only AFI, system ID and SEL. Tha maximum size is 20 octotets

Levels of Routing in OSI networks:

Level 0 routing: between ES and IS

Level 1 routing: between ES nodes within the same area

Level 2 routing: between ES nodes which are in the different area of the same domain

Level 3 routing:between ES nodes which are in different domains

IS-IS provice level 1 and level 2 routing. BGP  for inter-autonomous system routing in TCP/IP is fairly analogy of Level 3 routing.

default-information originate in different routing protocols

RIP

To generate a default route into Routing Information Protocol (RIP), use the default-informationoriginate command in router configuration mode. To disable this feature, use the no form of this command.

Example:

router rip 
 version 2
 network 172.17.16.0
 default-information originate route-map condition
!
route-map condition permit 10
 match ip address 10
 set interface s1/0
!
access-list 10 permit 172.17.16.0 0.0.255.255
setinterface Indicates where to forward packets that pass a match clause of a route map for policy routing.

OSPF:

Default routes injected into a normal area can be originated by any OSPF router. The OSPF router does not, by default, generate a default route into the OSPF domain. In order for OSPF to generate a default route, you must use the default-information originate command.

There are two ways to advertise a default route into a normal area. The first is to advertise 0.0.0.0 into the OSPF domain, provided the advertising router already has a default route. The second is to advertise 0.0.0.0 regardless of whether the advertising router already has a default route. The second method can be accomplished by adding the keyword always to the default-information originate command.

Example:

router ospf 2
 network 5.0.0.0 0.255.255.255 area 1
 network 6.0.0.0 0.255.255.255 area 0
 default-information originate
ip route 0.0.0.0 0.0.0.0 6.0.0.3

Because it has a default route, Router originates a type 5 LSA with a link ID of 0.0.0.0. This is the result of the default-information originate command in its OSPF configuration.You can also add the always keyword to the default-information originate command to make a router originate a 0.0.0.0 type 5 LSA even if the router does not have a default route in its routing table.

BGP:

refer to item 6 in

https://yingsnotebook.wordpress.com/2017/03/29/bgp-network-summary-ii/

The default-information originate, redistribution from a different source, and network 0.0.0.0 are all similar in the resulting effect: they will inject the default route into BGP RIB and it will be advertised to all BGP neighbors. The difference is in the origin of the default route that is injected into BGP:

  • default-information originate causes the default route to be artificially generated and injected into the BGP RIB, regardlessly of whether it is present in the routing table.
  • Redistribution and network 0.0.0.0 will inject the default route into BGP only if the default route is currently present in the routing table, and additionally in the case of redistribution, if learned by a specific source protocol we are redistributing from.

The neighbor X.X.X.X default-originate is different in that the default route will be advertised only to this specific BGP neighbor and not to all existing BGP neighbors as with the previous approaches. The default route will not be present in the BGP RIB of the router that is configured with the neighbor X.X.X.X default-originate command and so it won’t be generally advertised to all BGP neighbors. At the same time, this command is similar to the default-information originate in that the default route is artificially generated and does not need to be present in the routing table.

Network summary route in different routing protocols

network summary route in different routing protocol

RIP:

  • auto summary: summary subnets into classful net route
  • ip summary-address: Automatic summary addressing always summarizes to the classful address boundary, while the ip summary-address router configuration command summarizes addresses on a specified interface.
    interface Ethernet1
    ip address 10.1.1.1 255.255.255.0
    ip summary-address rip 10.2.0.0 255.255.0.0
    no ip split-horizon
  • Automatic summary will override the configured summary address feature on a given interface except when both of the following conditions are true:
    •The configured interface summary address and the IP address of the configured interface share the same major network (the classful, nonsubnetted portion of the IP address).
    •Split horizon is not enabled on the interface.

OSPF:
OSPF is link state routing protocol that works on the concept of areas. All areas must have same LSDB (link state database); hence OSPF summarization can only done on the border routers i.e. on ABR (Area border router) and ASBR (Autonomous system boundary router).

  • Inter Area route summarization:
    To summarize routes towards another area, in ABR we can use the following command:
    area [area-id] range [ ip-address ] [mask ] [advertise | not-advertise |cost {cost}]
    It will remove subnets routes from advertising to other area but a summarized route.
  • External route summarization.
    Use the following command to help reduce the size of the routing table and allow an OSPF Autonomous System Boundary Router (ASBR) to advertise one external route as an aggregate for all redistributed routes that are covered by the address.
    summary-address network netmask

BGP:
network summary of BGP can be found here
https://yingsnotebook.wordpress.com/2017/03/27/bgp-network-summary/

BGP network summary II

  1. When generate summarized route, if AS_PATH in all subnets routes are the same, the summarized route will keep the same AS_PATH,
    if subnet routes have different AS_PATH, in generated summarized route AS_PATH will be set as noll.
    In order to keep AS_PATH track in summarized route, AS_SET option can be used in the command:
    aggregate-address 160.0.0.0 255.0.0.0 summary-only as-set
  2. BGP will select the best route to advertise to the peer. it follows the best route selection policy here:
    Local preference > AS_PATH > lowest Orignal code >the lowest multi-exit discriminator > eBGP route over iBGP > IGP metric to the BGP next hop > lowest router ID.

    First of all, routes need to be the valid route before it is qualified to best route selection. A valid route means that Router has route path towards the ip of NEXT_HOP

  3. eBGP will update NEXT_HOP will advertise the route to the peer, but iBGP will keep NEXT_HOP unchange. NEXT_HOP can be modified with command
    neighbor 170.10.20.1 next-hop-self
  4. Back door, if network 160.10.0.0 is learned from both eBGP and OSPF, since eBGP has lower AD, route learned from eBGP will be selected. This is not alway prefered. In that case,we can set backdoor as below
    network 160.10.0.0 backdoor

    Network 160.10.0.0 is treated as a local entry, but is not advertised as a normal network entry.  After this, 160.10.0.0 will use the route learned from OSPF instead of eBGP.

  5. synchronization is enabled by default in order to avoid blackhole in the network.
    it pretends a learned routes from being advertised to other peers if the same route cannot be learned from IGP route.
    There are 2 ways to solve blackhole problem:
    1, synchronization and redistribute all eBGP learned route into IGP route. While synchronizaton pretends a learned routes from being advertised to other peers if the same route cannot be learned from IGP route.
    2, configure iBGP on each router of the network and all iBGP routers build a full mesh peer network.
    This will bring high performance load if the network is too big and each router need run iBGP to maintain a big routing table. This problem is addressed by two ways: Confederation and reflectors.
  6.  Default route

The default-information originate, redistribution from a different source, and network 0.0.0.0 are all similar in the resulting effect: they will inject the default route into BGP RIB and it will be advertised to all BGP neighbors. The difference is in the origin of the default route that is injected into BGP:

  • default-information originate causes the default route to be artificially generated and injected into the BGP RIB, regardlessly of whether it is present in the routing table.
  • Redistribution and network 0.0.0.0 will inject the default route into BGP only if the default route is currently present in the routing table, and additionally in the case of redistribution, if learned by a specific source protocol we are redistributing from.

The neighbor X.X.X.X default-originate is different in that the default route will be advertised only to this specific BGP neighbor and not to all existing BGP neighbors as with the previous approaches. The default route will not be present in the BGP RIB of the router that is configured with the neighbor X.X.X.X default-originate command and so it won’t be generally advertised to all BGP neighbors. At the same time, this command is similar to the default-information originate in that the default route is artificially generated and does not need to be present in the routing table.

BGP network summary

When auto summary enabled:

  •  route advitised by network command, both summarized route and subnet route will be advitised
    1, network command without net mask will be regarded as classified network, summariezed network route will be generated and send to peer,will be matched when there is a subnet route entry in the routing table.
    2, network command with net mask will be matched when there is a subnet route entry in the routing table.
  •  route advertised by redistribute, only summarized route will be advitised. no subnet route entry.

When auto summary disabled:

  • network command with net mask configured need to be used to match route entry in routing table, matching will be precisely for both prefix and network. Only the route that precisely matchs the network command will be advertised
  • redistribute route will following the same rule as network command

Use aggregate command to manually generate a summary net route:

Aggregate command can be used to manually advertise a summary net, when there is ‘summary-only’ configured, then only the summarized net route will be advertised, not any subnet route. But in order to be able to generate aggregate-address, there must be at least one subnet route available in the routing table.

  aggregate-address xx.0.0.0 255.0.0.0 summary-only